Can not initialize the device. (1.5 final)

oldest posts, i.e. the issues probably dont exists or not valid anymore for the up-to-date DD version. Please let us know if the problems still exist.

Moderators: Dreamer, FredB

User avatar
Cjcr
Just popping in
Posts: 9
Joined: Wed Apr 07, 2010 9:52 am

Can not initialize the device. (1.5 final)

Postby Cjcr » Sun Apr 25, 2010 9:37 am

Image

- Have DVB-T and DVB-S/S devices, and don't work.

bdas.log:

Code: Select all

[04/25/10 18:33:12 :         ] >> DeviceGetList
[04/25/10 18:33:12 :       31] - Filter [AVerMedia BDA DVBT Tuner]
[04/25/10 18:33:12 :       31] - Filter [TBS 6980 BDA DVBS/S2 A Tuner/Demod]
[04/25/10 18:33:12 :       31] - Filter [TBS 6980 BDA DVBS/S2 B Tuner/Demod]
[04/25/10 18:33:12 :       31] << DeviceGetList   pDL->Count:3
[04/25/10 18:33:12 :       31] StartDevice()  dwDeviceNo:0
[04/25/10 18:33:12 :       31] >> DeviceGetList
[04/25/10 18:33:12 :       47] - Filter [AVerMedia BDA DVBT Tuner]
[04/25/10 18:33:12 :       47] - Filter [TBS 6980 BDA DVBS/S2 A Tuner/Demod]
[04/25/10 18:33:12 :       63] - Filter [TBS 6980 BDA DVBS/S2 B Tuner/Demod]
[04/25/10 18:33:12 :       63] << DeviceGetList   pDL->Count:3
[04/25/10 18:33:12 :       78] BDA Device Name: [AVerMedia BDA DVBT Tuner]      (Tuner Type:3)
[04/25/10 18:33:12 :       78] add_filter (AVerMedia BDA DVBT Tuner)
[04/25/10 18:33:12 :      125] add_filter (Microsoft DVBT Network Provider)
[04/25/10 18:33:12 :      172] TuningSpace Name: 'Antenna'  NetworkType: {00000000-0000-0000-0000-000000000000}
[04/25/10 18:33:12 :      172] TuningSpace Name: 'ATSC'  NetworkType: {0DAD2FDD-5FD7-11D3-8F50-00C04F7971E2}
[04/25/10 18:33:12 :      172] TuningSpace Name: 'ATSCCable'  NetworkType: {0DAD2FDD-5FD7-11D3-8F50-00C04F7971E2}
[04/25/10 18:33:12 :      172] TuningSpace Name: 'AuxIn1'  NetworkType: {00000000-0000-0000-0000-000000000000}
[04/25/10 18:33:12 :      172] TuningSpace Name: 'Cable'  NetworkType: {00000000-0000-0000-0000-000000000000}
[04/25/10 18:33:12 :      172] TuningSpace Name: 'DD DVB-T'  NetworkType: {216C62DF-6D7F-4E9A-8571-05F14EDB766A}
[04/25/10 18:33:12 :      172] TuningSpace Name: 'DD2 DVB-S'  NetworkType: {FA4B375A-45B4-4D45-8440-263957B11623}
[04/25/10 18:33:12 :      172] TuningSpace Name: 'DD2 DVB-T'  NetworkType: {216C62DF-6D7F-4E9A-8571-05F14EDB766A}
[04/25/10 18:33:12 :      172] Enumeration found 8 tuning spaces
[04/25/10 18:33:12 :      188] Found TuningSpace
[04/25/10 18:33:12 :      188] BDACardType: 0
[04/25/10 18:33:12 :      188] GetTunerInterfaces: Pin types (2) :
[04/25/10 18:33:12 :      188] GetTunerInterfaces:      Pin 0 Type = Input
[04/25/10 18:33:12 :      188] GetTunerInterfaces:      Pin 1 Type = Output
[04/25/10 18:33:12 :      188] GetTunerInterfaces: Node types (2):
[04/25/10 18:33:12 :      203] GetTunerInterfaces:      Node 0 Type = 0
[04/25/10 18:33:12 :      203] GetTunerInterfaces:      Node 1 Type = 1
[04/25/10 18:33:12 :      203] GetTunerInterfaces: Node interfaces:
[04/25/10 18:33:12 :      203] GetTunerInterfaces:    Interfaces on NodeType 0   (2 interfaces):
[04/25/10 18:33:12 :      203] GetTunerInterfaces:       {71985F47-1CA1-11D3-9CC8-00C04F7971E0} IID_IBDA_FrequencyFilter   
[04/25/10 18:33:12 :      203] GetTunerInterfaces:       {1347D106-CF3A-428A-A5CB-AC0D9A2A4338} IID_IBDA_SignalStatistics 
[04/25/10 18:33:12 :      203] GetTunerInterfaces:    Interfaces on NodeType 1   (2 interfaces):
[04/25/10 18:33:12 :      203] GetTunerInterfaces:       {EF30F379-985B-4D10-B640-A79D5E04E1E0} IID_IBDA_DigitalDemodulator
[04/25/10 18:33:12 :      203] GetTunerInterfaces:       {DDF15B12-BD25-11D2-9CA0-00C04F7971E0} IID_IBDA_AutoDemodulate     - QueryInterface FAILED ! - hr = 0x80004002
[04/25/10 18:33:12 :      250] add_filter (AVerMedia BDA Digital Capture)
[04/25/10 18:33:12 :      266] add_filter (Sample Grabber)
[04/25/10 18:33:12 :      266] add_filter (MPEG-2 Demultiplexer)
[04/25/10 18:33:12 :      281] add_filter (BDA MPEG0 Transport Information Filter)
[04/25/10 18:33:12 :      297] FAILED: cannot connect ms mpeg-2 demultiplexer filter to transport information filter

TeVii S470, TeVii S660, Prof 7500, TBS6980, TwinHan BlueCard 1020, AverMedia007 DVB-T... and more...

- System: P4 3Ghz, ATI HD4670, 1TB HDD, 2GB Ram. Windows 7 RTM x64 / Ubuntu 9.10.
User avatar
rel
relocation
Posts: 2025
Joined: Fri Jun 16, 2006 9:50 am

Postby rel » Sun Apr 25, 2010 10:10 am

something wrong with the Transport Information Filter
add_filter (BDA MPEG0 Transport Information Filter)


it should be MPEG2 , not MPEG0 ?!
probably one of other DVB applications you installed tried to override this filter ?! (possibly the ones bundled with device)
DVB Dream - because I have to dream about having time to code it
User avatar
Cjcr
Just popping in
Posts: 9
Joined: Wed Apr 07, 2010 9:52 am

Postby Cjcr » Sun Apr 25, 2010 10:19 am

rel wrote:something wrong with the Transport Information Filter
add_filter (BDA MPEG0 Transport Information Filter)


it should be MPEG2 , not MPEG0 ?!
probably one of other DVB applications you installed tried to override this filter ?! (possibly the ones bundled with device)

I have also other devices and do not work.
It seems you do not recognize the type of network (dvb-s, t, c...)

Using another bda.dev (dvbdream1.4) if it recognizes the type of network, although it is not compatible with DVBDream 1.5.

P.S: This site sometimes don't work.
TeVii S470, TeVii S660, Prof 7500, TBS6980, TwinHan BlueCard 1020, AverMedia007 DVB-T... and more...



- System: P4 3Ghz, ATI HD4670, 1TB HDD, 2GB Ram. Windows 7 RTM x64 / Ubuntu 9.10.
User avatar
Cjcr
Just popping in
Posts: 9
Joined: Wed Apr 07, 2010 9:52 am

Postby Cjcr » Mon Apr 26, 2010 1:16 pm

Any solution for this, Rel?

Thanks.
TeVii S470, TeVii S660, Prof 7500, TBS6980, TwinHan BlueCard 1020, AverMedia007 DVB-T... and more...



- System: P4 3Ghz, ATI HD4670, 1TB HDD, 2GB Ram. Windows 7 RTM x64 / Ubuntu 9.10.
User avatar
rel
relocation
Posts: 2025
Joined: Fri Jun 16, 2006 9:50 am

Postby rel » Mon Apr 26, 2010 1:38 pm

no...
it looks like something overrided your default BDA filters..
maybe it will work if you try on another PC with clean windows / system install.
DVB Dream - because I have to dream about having time to code it
curro1
Not too shy to talk
Posts: 11
Joined: Sun Sep 17, 2006 2:12 pm

Postby curro1 » Mon Apr 26, 2010 2:01 pm

I have another AverMedia DVB-T card: DVBdream 1.4 and 1.5 also says "Unknown", but the card works correctly (my problem is another: v1.5 can't record anything, but that is another story.. xDD).

This is from v.1.4i, where I can select device, watch TV, and record correctly:

[04/26/10 22:51:41 : 31] - 0) BDA MPEG0 Transport Information Filter (Looking for:-1)
[04/26/10 22:51:41 : 31] - 0) BDA MPEG2 Transport Information Filter (Looking for:-1)
[04/26/10 22:51:41 : 31] LoadFilter(KSCATEGORY_BDA_TRANSPORT_INFORMATION, pFilterGraph, &m_pTIF..) OK
[04/26/10 22:51:41 : 249] StartDevice() OK

And the same in v1.5 final:
[04/26/10 11:07:04 : 31] - 0) BDA MPEG0 Transport Information Filter (Looking for:-1)
[04/26/10 11:07:04 : 31] - 0) BDA MPEG2 Transport Information Filter (Looking for:-1)
[04/26/10 11:07:04 : 31] LoadFilter(KSCATEGORY_BDA_TRANSPORT_INFORMATION, pFilterGraph, &m_pTIF..) OK
[04/26/10 11:07:04 : 265] StartDevice() OK
User avatar
Cjcr
Just popping in
Posts: 9
Joined: Wed Apr 07, 2010 9:52 am

Postby Cjcr » Mon May 03, 2010 1:07 am

Hi,

I solved the problem partially.
Deleting all registry keys containing "BDA MPEG0" solves the problem and now I can start the device.

That if, still does not detect the type of network.
TeVii S470, TeVii S660, Prof 7500, TBS6980, TwinHan BlueCard 1020, AverMedia007 DVB-T... and more...



- System: P4 3Ghz, ATI HD4670, 1TB HDD, 2GB Ram. Windows 7 RTM x64 / Ubuntu 9.10.
User avatar
rel
relocation
Posts: 2025
Joined: Fri Jun 16, 2006 9:50 am

Postby rel » Mon May 03, 2010 1:34 am

That if, still does not detect the type of network.


it wont display type for BDA interface, its normal (cancelled feature)
DVB Dream - because I have to dream about having time to code it
User avatar
Cjcr
Just popping in
Posts: 9
Joined: Wed Apr 07, 2010 9:52 am

Postby Cjcr » Mon May 03, 2010 1:59 am

ammm okay. thanks.
TeVii S470, TeVii S660, Prof 7500, TBS6980, TwinHan BlueCard 1020, AverMedia007 DVB-T... and more...



- System: P4 3Ghz, ATI HD4670, 1TB HDD, 2GB Ram. Windows 7 RTM x64 / Ubuntu 9.10.

Return to “Rusty Posts”

Who is online

Users browsing this forum: No registered users and 1 guest